Carrier Issues - Stamps.com
Incident Report for ShipWorks
Resolved
Thank you for your patience while our partners worked to resolve your issues with processing Stamps.com shipments. You should be able to process shipments without any further interruption.

Thank you
Posted Oct 20, 2022 - 09:05 PDT
Investigating
ShipWorks is aware of the technical issues impacting the ability to process your shipments using Stamps.com. We are actively monitoring the status of these issues and will provide updates as they become available.

You can also check the status of this Incident on Stamps.com's Status Page

Thank you for your patience!
Posted Oct 20, 2022 - 08:04 PDT
This incident affected: Carriers (Stamps.com).