Carrier Issues
Incident Report for ShipWorks
Resolved
Thank you for your patience while ShipWorks Engineers worked to resolve your issue printing labels.

You should be able to print USPS labels without interruption.

Thank you.
Posted Jan 30, 2024 - 12:11 PST
Update
We are continuing to work on a fix for this issue.
Posted Jan 30, 2024 - 10:12 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 30, 2024 - 07:23 PST
Investigating
ShipWorks is aware of the technical issues impacting integrated carriers. We are actively monitoring the status of these issues and will provide updates as they become available.
Thank you for your patience!
Posted Jan 30, 2024 - 05:58 PST
This incident affected: Carriers (Stamps.com).