USPS suspending shipments to Canada

Incident Report for ShipWorks

Resolved

This incident has been resolved.
Posted Jan 17, 2025 - 16:37 CST

Update

We are continuing to monitor for any further issues.
Posted Jan 06, 2025 - 14:21 CST

Update

Please see below for the latest updates as of December 20, 2024
Posted Dec 20, 2024 - 13:23 CST

Update

Please see below for the latest updates as of December 20, 2024
Posted Dec 20, 2024 - 13:22 CST

Update

We are continuing to monitor for any further issues.
Posted Dec 11, 2024 - 16:28 CST

Monitoring

Effective Monday, January 6, 2025, USPS will resume full service to Canada and begin accepting mail and packages again. Starting Monday, January 6, 2025, you can create and print USPS labels destined for Canada using your ShipWorks account. Please note that due to the recent CUPW strike and accumulated backlog, shipments may experience delays.

GlobalPost: Effective Monday, January 6, 2025, GlobalPost has resumed full service to Canada, including P.O. Boxes and previously restricted postal codes, and is now accepting mail and packages again for these destinations.
Posted Nov 27, 2024 - 19:30 CST
This incident affected: Carriers (Stamps.com, UPS, Endicia).