Delayed Printing of Shipping Labels
Incident Report for ShipWorks
Resolved
ShipWorks engineers have fixed the technical issue and all systems are functioning normally. Thank you for your patience!
Posted Nov 09, 2020 - 10:25 PST
Investigating
ShipWorks engineers have identified a delay that may temporarily affect some of our customers’ ability to print shipping labels. We are sorry for the inconvenience and will update with a resolution soon!
Posted Nov 09, 2020 - 09:11 PST
This incident affected: Carriers (Stamps.com).