ShipWorks Performance
Incident Report for ShipWorks
Resolved
This incident has been resolved.
Posted Jun 13, 2023 - 14:00 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 13, 2023 - 13:46 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 13, 2023 - 13:43 PDT
Investigating
Investigating - ShipWorks is aware of the current performance issues impacting ShipWorks We are actively investigating this issue.
We will provide updates as they become available to us. Thank you for your patience!
Posted Jun 13, 2023 - 12:27 PDT
This incident affected: ShipWorks.