Login Issues with ShipWorks
Incident Report for ShipWorks
Resolved
ShipWorks engineers have fixed the login issue and all systems are functioning normally. Thank you for your patience!
Posted May 25, 2021 - 16:03 PDT
Investigating
ShipWorks engineers have identified an issue that may temporarily affect some of our customers' ability to login into the ShipWorks software and website. We are sorry for the inconvenience and will update with a resolution soon!
Posted May 25, 2021 - 12:44 PDT
This incident affected: ShipWorks Warehouse Services (ShipWorks HUB).