USPS Label Generation Error
Incident Report for ShipWorks
Resolved
This incident has been resolved.
Posted Jul 26, 2023 - 11:15 PDT
Investigating
Good morning. ShipWorks is currently experiencing errors when trying to create USPS labels. We are aware of the impact this has on you, and we are working to identify the issue! We will provide frequent updates on our progress.

Thank you for your continued patience, and check back soon!
Posted Jul 26, 2023 - 06:01 PDT
This incident affected: Carriers (Stamps.com).