Delayed Printing of Shipping Labels
Incident Report for ShipWorks
Resolved
Thank you for your patience. The delays in printing have been resolved.
Posted Jul 28, 2021 - 14:37 PDT
Investigating
ShipWorks engineers have identified a delay that may temporarily affect some of our customers’ ability to print shipping labels. We are sorry for the inconvenience and will update with a resolution soon!
Posted Jul 28, 2021 - 12:06 PDT
This incident affected: Carriers (Stamps.com).