Carrier Issues

Incident Report for ShipWorks

Resolved

Thank you for your patience while ShipWorks Engineers worked to resolve your issues.
Posted Jan 22, 2025 - 11:05 CST

Investigating

ShipWorks Engineers are aware of the technical issues impacting FedEx shipments. We are actively working to resolve this issue and will provide updates as they become available to us.

Thank you for your patience!
Posted Jan 22, 2025 - 08:16 CST
This incident affected: Carriers (FedEx).