Delayed Printing of UPS Shipping Labels
Incident Report for ShipWorks
Resolved
ShipWorks engineers have fixed the print issue and all systems are functioning normally. Thank you for your patience!
Posted Oct 25, 2019 - 12:21 PDT
Investigating
ShipWorks engineers have identified a delay that may temporarily affect some of our customers’ ability to print shipping labels. We are sorry for the inconvenience and will update with a resolution soon!
Posted Oct 25, 2019 - 08:21 PDT
This incident affected: Carriers (UPS).