Carrier Issues

Incident Report for ShipWorks

Resolved

Thank you for your patience while UPS worked to resolve your issues.
Posted Aug 05, 2024 - 09:10 CDT

Update

We are continuing to investigate this issue.
Posted Aug 05, 2024 - 08:39 CDT

Investigating

ShipWorks is aware of the technical issues impacting UPS Shipments We are actively monitoring the status of these issues and will provide updates as they become available.

Thank you for your patience!
Posted Aug 05, 2024 - 08:38 CDT
This incident affected: Carriers (UPS).