Issues with Priority Shipping
Incident Report for ShipWorks
Resolved
Thank you for your patience while our partners worked to resolve your issues with processing Priority shipments. You should be able to process your shipments without further interruption.

Thank you for your patience!
Posted Sep 30, 2022 - 09:23 PDT
Monitoring
ShipWorks is aware of the technical issues impacting the ability to process Priority labels. We are actively monitoring the status of these issues and will provide updates as they become available.

You can also check the status on Stamps.com's Status Page or Endicia's Status Page

Thank you for your patience!
Posted Sep 30, 2022 - 07:23 PDT
Investigating
ShipWorks is aware of the technical issues impacting the ability to process Priority labels. We are actively monitoring the status of these issues and will provide updates as they become available.

Thank you for your patience!
Posted Sep 30, 2022 - 05:40 PDT
This incident affected: Carriers (Stamps.com).