Support Service Issues
Incident Report for ShipWorks
Resolved
Thank you for your patience while our integrators worked to resolve your issues.
Posted Apr 22, 2024 - 09:35 PDT
Investigating
ShipWorks Support is aware of the technical issues impacting inbound phone calls. We are actively monitoring the status of these issues and will provide updates as they become available to us.
Thank you for your patience!
Posted Apr 22, 2024 - 08:31 PDT
This incident affected: Support Services (Phone Support).