Carrier Issues
Incident Report for ShipWorks
Resolved
This incident has been resolved.
Posted Sep 27, 2021 - 06:04 PDT
Investigating
ShipWorks is aware of the technical issues impacting integrated carriers. We are actively monitoring the status of these issues and will provide updates as they become available.
Thank you for your patience!
Posted Sep 24, 2021 - 13:33 PDT
This incident affected: Carriers (Stamps.com, UPS).