ShipWorks Service Disruption

Incident Report for ShipWorks

Resolved

Thank you for your patience while our integrators worked to resolve your issues. Please close and reopen ShipWorks Platforms in order to reflect the changes made.
Posted Oct 20, 2025 - 17:13 CDT

Identified

ShipWorks is currently experiencing performance issues due to an ongoing AWS service issue. We are actively monitoring their status and its impact on our platform. We will provide updates as they become available. Thank you for your patience.

You can view the AWS Health Dashboard here: AWS Status Page
.
Posted Oct 20, 2025 - 16:30 CDT
This incident affected: ShipWorks.