Delayed Printing of Shipping Labels
Incident Report for ShipWorks
Resolved
This incident has been resolved.
Posted Jan 25, 2021 - 09:29 PST
Update
We are continuing to investigate this issue.
Posted Jan 25, 2021 - 09:28 PST
Investigating
ShipWorks engineers have identified a delay that may temporarily affect some of our customers’ ability to print USPS shipping labels. We are sorry for the inconvenience and will update with a resolution soon!
Posted Jan 25, 2021 - 08:04 PST
This incident affected: Carriers (Stamps.com).