Carrier Issues
Incident Report for ShipWorks
Resolved
The issues with ShipWorks and postage have been resolved by Amazon. Please visit https://status.aws.amazon.com/ for any further updates.
Posted Dec 15, 2021 - 09:32 PST
Investigating
ShipWorks is aware of the Amazon Web Services issues impacting integrated carriers and purchasing postage with Stamps.com. We are actively monitoring the status of these issues and will provide updates as they become available.
Thank you for your patience!
Posted Dec 15, 2021 - 07:51 PST
This incident affected: Carriers (Stamps.com).