Delayed Printing of Shipping Labels
Incident Report for ShipWorks
Resolved
ShipWorks engineers have fixed the print issue and all systems are functioning normally. Thank you for your patience!
Posted Jul 12, 2021 - 09:02 PDT
Investigating
ShipWorks engineers have identified a delay that may temporarily affect some of our customers’ ability to print Scan Forms. We are sorry for the inconvenience and will update you with a resolution soon!
Posted Jul 12, 2021 - 07:55 PDT
This incident affected: Carriers (Stamps.com).