UPS Carrier Issues

Incident Report for ShipWorks

Resolved

Thank you for your patience while our integrators worked to resolve your issues. Please close and reopen ShipWorks Platforms in order to reflect the changes made.
Posted Apr 21, 2022 - 11:04 CDT

Investigating

ShipWorks is aware of the technical issues impacting UPS carrier. We are actively monitoring the status of these issues and will provide updates as they become available.

Thank you for your patience!
Posted Apr 19, 2022 - 09:43 CDT
This incident affected: Carriers (UPS).