ShipWorks
Incident Report for ShipWorks
Resolved
Thank you for your patience while ShipWorks Engineers worked to resolve your issues.
Posted Sep 26, 2024 - 11:41 CDT
Investigating
ShipWorks is aware of the technical issues impacting the ShipWorks Platform. We are actively working to resolve this issue.
We will provide updates as they become available to us. Thank you for your patience!
Posted Sep 26, 2024 - 11:24 CDT
This incident affected: ShipWorks and Carriers (UPS, FedEx).