Support Service Issues

Incident Report for ShipWorks

Resolved

This incident has been resolved.
Posted 3 years ago. Dec 16, 2021 - 19:08 CST

Investigating

Our support platform is currently experiencing an outage preventing users from reaching our support team, we are monitoring the situation. Please visit status.zendesk.com for more information.
Posted 3 years ago. Dec 16, 2021 - 15:03 CST
This incident affected: Support Services (Phone Support, Email Support).