DHL Express Canada Updates

Incident Report for ShipWorks

Update

DHL Express shipping operations in Canada will be suspended effective Friday, June 20, 2025, at 12 a.m. E.T.

As a result, DHL Express will suspend the collection of shipments destined to or dispatched from Canada as of Tuesday, June 17 at 9 p.m. E.T. until further notice.

More info: https://express-resources.dhl.com/Labour-Negotiation-Updates-EN.html
Posted Jun 16, 2025 - 18:49 CDT

Monitoring

DHL Express is fully prepared and has contingency plans in place during labor disruptions to continue servicing its customers. Effective June 8, 2025, you may continue printing shipping labels destined for Canada through DHL Express from ShipWorks.
Posted Jun 09, 2025 - 17:48 CDT
This incident affects: Carriers (DHL).