High rate of timeout errors - "An unexpected Error Occurred"

Incident Report for ShipWorks

Resolved

This incident has been resolved.
Posted Sep 26, 2023 - 13:31 CDT

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 26, 2023 - 11:56 CDT

Investigating

We are investigating widespread occurrences of timeouts and "An unexpected error occurred." error messages being returned for multiple carriers
Posted Sep 26, 2023 - 11:55 CDT
This incident affected: Carriers (Stamps.com, UPS, FedEx, Amazon Buy Shipping API, Endicia).