UPS

Incident Report for ShipWorks

Resolved

This incident has been resolved.
Posted Mar 25, 2023 - 11:15 CDT

Update

We are continuing to investigate this issue.
Posted Mar 25, 2023 - 11:03 CDT

Investigating

We are aware of an issue merchants are having with creating UPS labels. This is being investigated by our teams. When we have additional information, we will follow up here.
Posted Mar 25, 2023 - 09:49 CDT
This incident affected: Carriers (UPS).